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This tutorial will show you step by step how to use the program ALOHOMORA with the files provided in example1. This tutorial is written for use on a Windows platform and assumes that all genetic analysis programs, Perl scripts and DOS-batches are correctly installed and are available on a “cmd” command tool via the PATH variable. The SNPannotation files, spitted in genetic map and allele frequency files, are stored in C:\genetics\affy and the project data files in the directory C:\example1.

ALOHOMORA, Copyright (C) 2004 Franz Rüschendorf

ALOHOMORA comes with ABSOLUTELY NO WARRANTY

Caution: Alohomora, the Perl-scripts and the batches will delete w/o asking previously generated files with the extensions *.ps, *.out, *.plt, *.gp and some other temporary files either in the current working directory or in all chromosome subfolders. Don’t execute the scripts in folders where you want to save the results. 

How to start?

Open a command tool with the mouse: Press “START->Run”.

Enter cmd in the Open field and you will get a DOS command window.

Change the working directory to your project directory. In this example type

c:

cd example1
in the DOS command window. Your current working directory should now be C:\example1 and the DOS prompt look like “C:\example1>”.

Alternatively create a shortcut from C:\Windows\system32\cmd.exe on the desktop and change the properties to start cmd in your project folder.

Now start Alohomora: Type “alohomora”. The Alohomora main window should appear on your screen.
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Alohomora will read now several files.

1. the GDAS genotype file

2. the pedigree structure file “pedfile.pro”

3. the genetic map 

4. allele frequency file

5. mendelian error file (optional)

At first we select the GDAS genotype file:

Press the button Genotypefile and select the file “C:\example1\ex1.txt”.

Alohomora assumes that the pedigree file “pedfile.pro” is located in the same directory than the genotype file. The chip we use in example1 is the 10K Xba131 (11560 SNPs in the genotype file), so we select the Chip radio button “Xba131”. The optional Input Filter allows to skip SNPs when Alohomora reads in the genotype file. We activate the check box “w/o position”, that will skip all SNPs which have no position in the genetic map. We do not activate the “skip ME” check box (skip SNPs with Mendelian errors in one or more of the families), because we did not checked for Mendelian errors until now. An optional list with SNPs to skip can be used with the check button “skiplist”. Then a file with name “skiplist.txt” must be located in the current working directory. We don’t use this option in example1. The three Output Filters should not be selected now; they will affect the Linkage-format file creation later. Select Genetic map “deCode” and Allele frequencies “Caucasian”. To check or change the source of the selected genetic map or allele frequency files select in the menu bar Options->File Selection.

When all options are OK, then press the button Read Infiles.

After reading the files, Alohomora shows some summaries about the markers in the genetic map and in the genotype file, e.g. the number of markers on the autosomal- and X-chromosomes and the markers without genetic map. You will notice that there is a discrepancy between the genotype file (10560 SNPs) and genetic map (10555 SNPs), this is because 5 markers are redundant/doubled on the chip, they have different tsc-numbers, but identical rs-numbers. These 5 markers are not skipped here, they will be skipped when writing the linkage files later.

Quality Control

· Check Gender

At first we want to check the gender of each individual in the genotype file and compare it to the sex status stored in the pedigree file “pedfile.pro”. Select in the menu Check-> Gender. Alohomora counts for each individual the number of heterozygote genotypes from the 309 X-linked SNPs and if the amount is greater than 10% the program assumes that the individual is female, else it’s male. The normal amount of heterozygote genotypes in females is between 20-35% with this chip (consanguinity affects this value!). If there is a discrepancy between the sex status in the pedfile and the estimated gender from the genotypefile, then Alohomora will give a warning in the Main Window. In all cases Alohomora deletes heterozygote genotypes of male individuals of X-linked markers. This step has to be done here, because PedCheck will refuse his work as long as there are heterozygote genotypes from X-linked markers in male individuals.

· Graphical Relationship Representation (GRR)

The correct relationship between individuals should be controlled before running PedCheck (you waste time when you change the order of checks!).

Press the button GRR. Alohomora creates a file “grr_pedfile.dat” with all 11145 SNPs from the autosomal chromosomes, which can be loaded by GRR.

Start GRR and load the file “grr_pedfile.dat”. You have the choice to compare individuals within families or between families (all pairs). In example1 we have only one family, so we use the option “Within Family Pairs Only”. GRR calculates IBS Mean and StDev over all autosomal markers for each pair of individuals and shows a plot IBS Mean vs StDev. Parent-Offspring-, Sib-Sib-, Half-Sib-, Monozygotic Twins- and Unrelated– relationships can be well separated by different clusters. The Half-Sib cluster overlaps with Other Relatives (e.g. Uncle-Nephew, Grandparent-Grandchild, …). First Degree Cousins, Second Degree cousins, … show clusters between Half-Sibs and Unrelated. The color of the squares is defined by the pedfile.pro. If a square appears in a cluster of a different color then something is wrong with the relationship. Look on IBS details by selecting the squares with the mouse.

Reasons for wrong relationships may be DNA switches, wrong father ship, …

There is no error in the family of example1. (Try to simulate a DNA switch between parent and child in the genotype file or pedfile.pro by exchanging individual Ids and see what happens.)

Thanks to Goncalo Abecasis for this very useful program!

· Check for Mendelian Errors (ME) with PedCheck

Press button PedCheck and wait. In the DOS command window you see the progression of PedCheck. Due to the limitations of PedCheck, the 11145 autosomal SNPs are checked in sets of 1000 markers in one run and the X-linked SNPs in one set of 309 markers. The results of all runs “pedcheck.err” are merged together to one file “pedcheck.all”. Alohomora reads this file when the user selects one of the optional filters “skip ME” or “delete ME”. In the first case the user has to reload the genotype data (press buttons Clear and Read Infiles), when he wants to skip SNPs with Mendelian errors in all families. When the choice is “delete ME” in the output filter then all genotypes with Mendelian errors will be deleted only in those families, where they appear. 

In example1 is only one family, therefore both choices will lead to the same result. For a summary of the Mendelian errors and a genome-wide graphic 

select in the menu Plot->Plot PedCheck Errors.

The distribution of the SNPs with Mendelian errors over the genome is shown in a Gnuplot graphic and stored as text file.  For each SNP this function counts the errors by family (y-axis).  

Thanks to Jeff O`Connel for programming PedCheck

· Detection of unlikely genotypes with Merlin 

“Unlikely genotypes” are equivalent to double recombinations in a short chromosomal segment.  The reasons may be genotyping errors or a wrong SNP position in the genetic map.

Select  “delete ME”.

Select “delete not informative”.

The Output Filter option “delete not informative” will delete all SNPs, which are not informative in all individuals from all families. This happens when a SNP shows either only the A allele and NoCalls or only the B allele and NoCalls. In this case you will get the allele frequency 0 or 1 when you calculate the allele frequencies from the current dataset. For the detection of unlikely genotypes with the Merlin option “--error” we delete all not informative markers to speed up the calculation time.

Select the menu option “DataConversion->Merlin”.

This opens a Window for the creation of linkage format files with the option to modify the genetic model or to select a moving window of variable size.

Merlin can handle large amounts of markers with this small family of example1. We don’t use the moving window option.

Press the “OK” button.

Alohomora creates a directory “merlin”, subdirectories for each chromosome (c01, c02,…) and linkage format files in each subdirectory. For example in the folder merlin\c01\ the files datain.01 and pedin.01 are in standard linkage format, map.01 is an additional map file which can be use by the program “Mega2”(we don’t start Mega2 now) and merlin_map.01 is the map file for Merlin. 

Now before closing the Alohomora graphical user interface we save the window summaries in a file “ex1.log”.

Select the menu option “File->Save”.

Press button “END”.

File->Save creates a file ex1.log.

Back on the DOS command tool change working directory to the folder “merlin” and start Merlin, type

cd merlin

merlin_start

The Merlin calculation of example1 on a 2.66GHz Pentium computer will need ~26 minutes and ~500Mb ram when using the pedigree with loop and less than 1 minute and ~4.4Mb ram when calculating the nuclear family.

The script to start Merlin for each chromosome (no subsets of markers) is C:\bat\merlin_start.bat. This DOS-Batch does  

1. starts Merlin with the options --error and --npl.

2. calls pedwipe to clean the files from unlikely errors

3. starts Merlin again with the options --npl and --best with the cleaned data

In the first run Merlin is started with error detection on and non-parametric LODscore analysis (files: merlin.err and merlin.out). The second run makes a non-parametric LOD score analysis and a haplotyping with the cleaned data (files wiped.out and merlin.chr). 

With the help of Gnuplot we can have a genome-wide view of the non-parametric analysis, type

merlin_npl

wiped_npl

The X-chromosomal data was not wiped by pedwipe and recalculated by Merlin, but for a better comparison (same axis) of both plots, copy c23\merlin.out to c23\wiped.out and then the X-chromosomal data will appear in the wiped plot.

In the last step of Quality Control we will collect all merlin.err files to a file “unlikely.all”. This file can optionally be used to delete the unlikely genotypes when creating files for other linkage programs like Genehunter, Mega2 or Simwalk2.

Change the working directory from C:\example1\merlin to C:\example1 and start Alohomora.

cd ..

alohomora

In the Alohomora menu select “Utilities->Create Merlin unlikely list”, this opens the File Dialog; select one arbitrary merlin.err file. 

A new file “unlikely.all” should be created in the folder C:\example1. This file will be used when the user selects the Alohomora option “delete unlikely genotypes” before creating Linkage format files.

Thanks to Goncalo Abecasis for programming Merlin.

Linkage and Haplotype Analysis 

· Genehunter

The family in example1 is consanguine, the persons 4.1 and 2737 are cousins of second degree and the mode of inheritance is recessive. With Genehunter we want to do a parametric linkage analysis using the method of a moving window. Until now we used the genotyped part of the family (nuclear family) for quality control. Now it’s necessary to use a pedigree with the real loop. Store pedfile.pro as pedfile_nuc.pro and copy pedfile_loop.pro to pedfile.pro with the File Manager or type in a new DOS command tool  (working directory C:\example1) 

copy pedfile.pro pedfile_nuc.pro

copy pedfile_loop.pro pedfile.pro

Start Alohomora in the folder C:\example1. 

At first select the Alohomora options:

Chip:
Xba131

Input filter: w/o position and skip ME
Output filter: delete unlikely genotypes

Genetic map: deCode
Allele frequencies: Caucasian
Genotype file: C:\example1\ex1.txt
then press button ReadInfiles.

When all files were correctly read in then we select the menu 

“Check->Gender” and

“DataConversion->Genehunter”

In the Genehunter option window we select 

haplotyping: on
postscript total stat het: on
total stat het: on

Make Subsets: on 

In the entry field behind “Make Subsets” enter the size of a non-overlapping moving window, type “200”. Non-overlapping means: The last SNP in the first set is identical with the first SNP in the second set, etc .

Insert the name of your Genehunter executable if it’s different from the default name “gh2” (e.g. gh, ghi, gh21r5,…). For the x-linked markers (c23) Alohomora will use always the name “xghi”.

Type the “OK” button. 
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Alohomora creates now a directory “gh_200” with subdirectories for each chromosome (c01, c02, ..) and sets of linkage-format files with 200 SNPs in each set. For example the files datain_1.01, map_1.01, pedin_1.01 and setup_1.01 belong to the first set of 200 markers on chromosome 1. (Second set: datain_2.01, map_2.01, pedin_2.01 and setup_2.01). 

“Setup_1.01” is the Genehunter batch to calculate the first set of chromosome 1.

In the gh_200 folder there are two batches: “gh_start.sh” a UNIX shell script and “gh_start.bat” a DOS batch to start Genehunter genome-wide set after set on all chromosomes. The scripts will delete (old) files with the extensions “*.ps, *.out and *.dump“ in all chromosome folders! So be careful, don’t start these scripts in other folders, where you want to save old results.

Save your current environment, close Alohomora, change the working directory to gh_200 and start Genehunter.

Select in the menu “Utilities->Save current Environment”

Press button “End”

In the DOS-Command tool type

cd gh_200

gh_start.bat

On a Pentium 4 Windows 2000 computer with a 2.66 MHz CPU and 1 Gb ram the Genehunter scan will need about 1h 50min. This will block your computer for other tasks. 

### UNIX stuff only ####

If you have UNIX workstations available in your workgroup, then transfer the folder gh_200 to the UNIX platform, transform the script gh_start.sh into UNIX-format, make the shell script executable and start the script with nohup (this allows to logout while a job is running). In the folder gh_200 of the UNIX workstation type:

dos2unix gh_start.sh

chmod +x gh_start.sh

/usr/bin/nohup ./gh_start.sh &

### END UNIX stuff ###

After Genehunter has finished it’s calculations on each chromosome we want i) to check if there are errors or warning in the Genehunter outfiles and ii) make a genome-wide view of the LOD- and NPL scores, as well of the information content.

In the genehunter folder C:\example1\gh_200 type

gh_errors

This command creates a file “gh_errors.out” and writes, if there are any errors or warnings in the Genehunter outfiles, all lines which match the words “ERR|SKIP|WARN|FAIL|PVECT” to this file. If there is no error or warning in a Genehunter outfile, then only the file name will be written. It’s strongly recommended to execute the script gh_errors after each Genehunter run and before making the LOD plots!

For a graphical plot of the scores GNUPLOT must be installed (the name must be gnuplot.exe and not wgnupl32.exe).   Type 

gh_snp_lod

gh_snp_npl

gh_snp_info

The name “gh_snp_lod” will execute the batch gh_snp_lod.bat, which in turn calls the line “perl c:\bat\gh_snp_lod.pl”.

Gnuplot will show the genome-wide Genehunter LOD- and NPLscores and the Information Content, one chromosome after each other on the x-axis. The plots will be stored in postscript format “gh_snp_lod.ps”, “gh_snp_npl.ps” and “gh_snp_info.ps”.  

The LOD plots indicate two regions with a LOD > 3 on chromosomes 3 and 9. A LOD score of ~3.2 should be the maximal LOD in this family. The corresponding Genehunter postscript plots, which include these two peaks, are c03\gh_plot_1.ps on chromosome 3 and  c09\gh_plot_3.ps on chromosome 9.

Thanks to Leonid Kruglyak for programming Genehunter.

· HaploPainter with Genehunter files

The Genehunter file haplo.dump can be represented by HaploPainter. Type

haplopainter

When the graphical user interface of Haplopainter is started load the pedigree file, the haplo.dump file and the genetic map file in this order. Select the files from the folder C:\example1\gh_200\c03.

Use “File->Import Pedigrees->Prae-Makeped” and select “pedin_1.03”,

“File->Import Haplotypes->Genehunter” and select “haplo_1.dump” and

“File->Import Map File-> Mega2” and select “map_1.03”. Now the pedigree with haplotyping, marker names and genetic map of 200 markers should be shown. For a better view and printing reduce the size of the haplotying to the first 10 markers, this includes the region of the high LOD score.

In the menu bar select “Options->Configuration”, in the configuration window “Hap-D” and highlight the first 10 markers, press “OK”. Then “Edit->Fit View”, “Edit->Zoom In”, “File->Export-> Current Pedigree as Postscript”.

The recombination events shown in this graphic (between marker 5 and 6, sample 2212 and father 4-1) are not necessary the ones estimated by Genehunter. Shown is the first informative recombination event. Marker 4 and 5 are not informative in sample 4-1, so the recombination event could also be happened in the smaller gaps between marker 3 and 4 or marker 4 and 5. 

From the chromosome 9 folder (c09) we select the files “pedin_3.09”, “haplo_3.dump” and “map_3.09”. Moving Window 3 of chromosome 9 contains 146 markers. The corresponding Genehunter LOD score postscript file is “lod-plot_3.ps”. There are two regions with a high LOD score; the first includes two markers and the second eleven markers. With “Option->Configuration” and “Hap-D” select smaller regions (e.g. the last 15 markers for the second region) for a better view.  

In this pedigree of example 1 there were 3 regions identified with a LOD score  > 3 and where the haplotyping is matching the genetic model. The number and the size of these regions can only be reduced by sampling more affected or unaffected family members or by sampling additional families with the same disease.  Unless there are no more samples available the disease/trait-causing gene must be searched in all 3 regions.

Many thanks to Holger Thiele for writing HaploPainter

· Allegro

The Allegro run of family 1 with loop does not need a Moving Window when ~800 Mb ram are available on your workstation. On a Pentium 4 Computer with 2.66 GHz Allegro needs only ~7 minutes.

Start Alohomora in the folder C:\example1. 

At first select the Alohomora options:

Chip:
Xba131

Input filter: w/o position and skip ME
Output filter: delete unlikely genotypes

Genetic map: deCode
Allele frequencies: Caucasian
Genotype file: C:\example1\ex1.txt
then press button ReadInfiles.

When all files were correctly read in then we select the menu

“Check->Gender” and

“DataConversion->Allegro”

The Create Linkage Format Files Window should appear.
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Don’t activate the Check button “Moving Window”. Press “OK”.

Alohomora creates a folder “allegro” with subdirectories and files for each chromosome (e.g. datain.01, pedin.01 and map.01 for chromosome 1). 

Close Alohomora; press the “END” button. 

In the cmd-command window change the working directory to the allegro folder and start a Perl-script to run Allegro on all chromosomes.

cd allegro 

perl C:\bat\allegro_start.pl

In the C:\bat\ folder there are two scripts to run Allegro 1) “allegro_start.pl” for a whole genome Allegro run without a moving window and 2) “allegro_scan_start.pl” for a whole genome Allegro run with a moving window.

When Allegro has finished all calculations create a whole genome LOD plot, type 

allegro_lod

The resulting Gnuplot graphics should show the same results as the Genehunter run, a LOD score > 3 on chromosome 3 and 9.

Many thanks to  Daniel F. Gudbjartsson and Kristjan Jonasson for programming Allegro

· HaploPainter with Allegro files

Allegro has produced 4 different haplotype files founder.xx, haplo.xx, ihaplo.xx and inher.xx for each chromosome. The file founder.xx shows the original alleles and the most likely founder haplotypes as well for individuals which are not genotyped. Start HaploPainter and load, for example on chromosome 3, the pedigree file pedin.03, the haplotype file founder.03 and the map file map.03.

HaploPainter

“File->Import Pedigrees->Prae-Makeped” and select “pedin.03”.

“File->Import Haplotypes->Allegro” and select “founder.03”.

“File->Import Map File-> Mega2” and select “map.03”.

“Options->Configuration” in window “Hap-D” highlight the first 10 markers.

“OK”

“Edit->Fit View”

“Edit->Zoom In”

“File->Export-> Current Pedigree as Postscript”.

Close HaploPainter.

For discussion of the example 1 result see the Genehunter section.

Several other excellent HaploPainter options are described the manual from the HaploPainter homepage.

Many thanks to Holger Thiele for writing HaploPainter

· Simwalk2

There is no need to examine example 1 with Simwalk2, because this pedigree is small enough for Merlin, Genehunter and Allegro (bits 15). For completion of this tutorial we show here how to convert the data with the help of Mega2 and start Simwalk2. 

Programs, which use the Mendel format like CriMap or Simwalk2, have a restriction to use numerical individual Ids. In the example 1 “pedfile.pro” the ungenotyped samples are coded as 1.1, 1.2, 2.1… and Simwalk2 does not accept the non-numerical dot in the current sample coding. So it’s essential to convert these Ids. E.g., open pedfile.pro with a text editor and substitute all “.” with “0”. This transformation is allowed in our small example family since all sample Ids remain unique. Save the pedfile.pro.

Start Alohomora and load the genotype data with the previously used options.

alohomora

Select options and press button ”ReadInfiles”.

“Check->Gender” and

“DataConversion->Mega2”

The Create Linkage Format Files Window should appear.
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The running time of Simwalk2 location score analysis is increasing exponential with the number of markers (in contrast to the description on the Simwalk2 homepage). Selecting a small moving window, here 30 markers, will speed up running time.

Activate check button “Make Subsets” and insert 30 (markers) in the entry field.

“OK”

Alohomora creates a folder “mega2_30” with chromosome subfolders, Mega2-format linkage files and a UNIX-start-script “mega2sw_lod_start.sh” to run Mega2 with the Simwalk2 option “Location Score Analysis” with a moving window for UNIX platforms. The script “mega2sw_lod_start.sh” was tested on Sun Solaris and Linux platforms (I never tested Simwalk2 on a Windows systems). 

Transfer the complete folder “mega2_30” to a UNIX platform.

Open a shell tool and change the working directory to the mega2_30 folder.

Convert the script “mega2sw_lod_start.sh” into UNIX format.

dos2unix mega2sw_lod_start.sh

Make the script executable.

chmod +x mega2sw_lod_start.sh

Transfer the script d2uall.sh to the UNIX platform and make it accessible and executable. D2uall.sh converts all files in a folder from DOS to UNIX format, because we generated the data on a Windows platform. Start the script with nohup.

/usr/bin/nohup ./mega2sw_lod_start.sh &

This gives the possibility to logout when calculation time is long.

After Simwalk2 has finished calculations on all chromosomes plot transfer the data back to your Windows computer and show the results with Gnuplot. In the mega2_30 folder execute:

sw_snp_lod

If you see more peaks in this plot as compared to the Allegro LOD score plot then control if this happens at the edges of the 30 marker window. In general the “Information Content” drops at the end of a chromosome and, when using a moving window, in each windows at both edges. When analysing 870 SNPs (chromosome 1) simultaneously the information content is much higher as compared with 30 microsatellites, but we loose this information when using the moving window method. The use of a small moving window sizes with Simwalk2 will decrease calculation time, but can lead to more false positive results at the edges of our moving window.

Thanks to Daniel E. Weeks, Nandita Mukhopadhyay, Lee W. Almasy and William Mullvihill for programming MEGA2

Thanks to Eric Sobel, Kenneth Lange and Daniel E. Weeks for Simwalk2

Many thanks for your interest in ALOHOMORA,

have fun,

please sent comments and bug reports to fruesch@mdc-berlin.de

